Chrome no longer supports Java applets from 1 Sep 2015



Chrome no longer supports Java applets from 1 Sep 2015
Chrome version 45 drops support for Java (NPAPI) which impact plugins for UTRADE Web.
We suggested clients to use other web browsers (e.g. IE, Firefox etc) for UTRADE Web trading. 
Please click here for the updated system requirement. We apologise for any inconvenience caused. 







Close this page